Jump to content
  • Join the online East Midlands astronomy club today!

    Test

EQ6R-Pro Connection for Leisure Battery


Recommended Posts

Information needed on how to connect my New EQR6 to a leisure battery, can i go down to B&Q or something like and buy the female end of a cigarette lighter and some wire and make a connection up or is it not that simple.

I do have a power supple but the connections to the power supply are the two open ended wires that go into positive and negative,  I will need the same type of connection as has needed for the leisure battery to get the EQR6 to work. 

Please Help

Link to post
Share on other sites
  • Replies 5
  • Created
  • Last Reply

Top Posters In This Topic

  • Paul Tomo

    2

  • tonylum

    2

  • Clive

    1

  • Bottletopburly

    1

Top Posters In This Topic

Popular Posts

forgot to say, make sure you connect your adaptor  correct polarity,  check if centre pin on connection is positive/ negative, as would suspect reverse polarity will blow the mount,  not trying to tea

All I would say is check, check again and then triple check that the positive and negative supply inputs to the mount are on the correct pins. You'll only get one chance to get it wrong.

Is there a caravan shop near you? They usually stock a "quick connector" which fits a round post battery, mine are red and blue for correct polarity try Amazon .AUTOUTLET Quick Release Battery Terminals Clamps Car Caravan Motorhome Terminal Pair

Link to post
Share on other sites

forgot to say, make sure you connect your adaptor  correct polarity,  check if centre pin on connection is positive/ negative, as would suspect reverse polarity will blow the mount,  not trying to teach you how to suck eggs though.😉

Link to post
Share on other sites

All I would say is check, check again and then triple check that the positive and negative supply inputs to the mount are on the correct pins. You'll only get one chance to get it wrong.

Link to post
Share on other sites

The power supply that i brought last year and never used is now out of its box and connected to my mount so and working perfect. I will sort the leisure battery connection at a later date. Thanks

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.