Jump to content
  • Join the online East Midlands astronomy club today!

    With active forums, two dark sites and a knowledgeable membership, East Midlands Stargazers has something for everyone.

Speedlink Strike FX


Teslar
 Share

Recommended Posts

Well I've been using this to remotely control my mount through EQMod for a year now and it worked perfectly. Then last night when I was setting up I took it out and there was no life in it. I thought a quick charge would sort that and 1 hour later there was still no life in it. I pressed the reset button and tried again but still no sign of life :(

Any ideas people ??

Link to comment
Share on other sites

To my surprise I just plugged it in again and the lights started to flash so it seems to have revived its self :) I'll have a play later just to make sure it's controlling the mount and if so I'll cancel the search for a replacement :D

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.